«Errar es de humanos, pero un auténtico desastre solo puede ser informático» - Victor Hugo

En el paquete de ofimática de Microsoft (Word, PowerPoint, etc.), el programa Microsoft Excel es uno de los más utilizados, pero no siempre el más controlado por los usuarios.

Ya sea que tengas tablas dinámicas u otro tipo de tablas en tu archivo de Excel, hay muchas fórmulas que te ayudarán a organizar y calcular datos. Aparte de las fórmulas básicas para sumar, multiplicar o restar, hay varias funciones que hacen posible elegir las condiciones de clasificación de la hoja de cálculo de Excel.

¿Cómo puedes usar y aprovechar las funciones de Excel? Y lo más importante, ¿qué es una función de comparación lógica? Como si fuera un auténtico curso de Excel, te informamos sobre las fórmulas de Excel que puedes administrar en tu hoja de cálculo.

¡Descubre con Superprof las funciones básicas de Excel! Ahora también con un curso excel online.

Los/las mejores profesores/as de Informática que están disponibles
José angel
4,9
4,9 (43 opiniones)
José angel
6€
/h
Gift icon
¡1a clase gratis!
Pedro
4,9
4,9 (10 opiniones)
Pedro
12€
/h
Gift icon
¡1a clase gratis!
Rony
5
5 (37 opiniones)
Rony
30€
/h
Gift icon
¡1a clase gratis!
Juan
4,9
4,9 (11 opiniones)
Juan
25€
/h
Gift icon
¡1a clase gratis!
Arber
4,9
4,9 (5 opiniones)
Arber
25€
/h
Gift icon
¡1a clase gratis!
Daniel
4,9
4,9 (12 opiniones)
Daniel
35€
/h
Gift icon
¡1a clase gratis!
Edgar
4,8
4,8 (11 opiniones)
Edgar
25€
/h
Gift icon
¡1a clase gratis!
Gloria
5
5 (12 opiniones)
Gloria
17€
/h
Gift icon
¡1a clase gratis!
José angel
4,9
4,9 (43 opiniones)
José angel
6€
/h
Gift icon
¡1a clase gratis!
Pedro
4,9
4,9 (10 opiniones)
Pedro
12€
/h
Gift icon
¡1a clase gratis!
Rony
5
5 (37 opiniones)
Rony
30€
/h
Gift icon
¡1a clase gratis!
Juan
4,9
4,9 (11 opiniones)
Juan
25€
/h
Gift icon
¡1a clase gratis!
Arber
4,9
4,9 (5 opiniones)
Arber
25€
/h
Gift icon
¡1a clase gratis!
Daniel
4,9
4,9 (12 opiniones)
Daniel
35€
/h
Gift icon
¡1a clase gratis!
Edgar
4,8
4,8 (11 opiniones)
Edgar
25€
/h
Gift icon
¡1a clase gratis!
Gloria
5
5 (12 opiniones)
Gloria
17€
/h
Gift icon
¡1a clase gratis!
Vamos

Las funciones de comparación lógica de Excel

Las funciones SI, Y, O y NO no son muy conocidas por los usuarios ocasionales del software de Microsoft Office y, sin embargo, pueden ser muy útiles para crear tablas en la hoja de cálculo. Permiten realizar comparaciones lógicas entre diferentes datos y según varias condiciones y varios criterios en la hoja de cálculo.

Comparación lógica en Excel
El software de Microsoft ofrece muchas posibilidades y funciones.

Estas funciones forman parte de lo que se llama una macro.

Una macro es un conjunto de instrucciones que permiten lograr un objetivo específico o dar un resultado. Se pueden incluir los cálculos de la tabla Excel (SUMA, etc.) como macros.

La función principal de Excel de este tipo es la función SI. Según el software:

«La función SI es una de las funciones más populares de Excel y permite realizar comparaciones lógicas entre un valor y un resultado que espera».

Esta función se usa generalmente al final de una línea de datos en una tabla. Está situada en la barra de herramientas. Se trata de una fórmula que puede tener dos resultados diferentes: A o B (por ejemplo). Poniendo el término SI, esto implica que, si se cumple la condición introducida por el SI, el resultado será A. Si no se cumple la condición, el resultado será B.

La función SI también se puede utilizar con las demás funciones (O, Y, NO). De hecho, a veces, se deben probar varias condiciones, o las condiciones deben ser verdaderas o falsas, o no corresponden con tu elección. Es por eso que las funciones Y, O y NO pueden usarse solas o con la función SI.

Una vez realizada la tabla y antes de abordar la configuración, es necesario establecer una «tabla de verdad». Lo mejor es crear un organigrama para evitar perderte entre todas las condiciones. Este debe presentar tu algoritmo para que puedas crear la fórmula sin errores, y sin olvidar los paréntesis y los puntos y coma (para dar los diferentes resultados posibles).

El punto y coma es esencial para separar los dos resultados posibles en la hoja de Excel. No lo olvides o la operación puede ser incorrecta.

¿Te gustaría saber también cómo hacer una tabla en Excel?

La función SI en un archivo Excel

Según el Soporte de Office, la definición de la función es la siguiente:

«La función SI hace posible realizar una comparación lógica entre un valor y una hipótesis al probar una condición y devolver un resultado verdadero o falso».

En otras palabras, la función SI permite comparar el valor numérico u otro de una celda según una condición definida por el usuario. Esto da un nuevo valor que sirve como respuesta.

La fórmula básica para utilizar la función es la siguiente:

=SI (Condición; Valor si se cumple la condición; Valor si no se cumple la condición)

Entonces es necesario usar lo que se llaman los operadores lógicos del software Microsoft Excel:

  • es igual a (=)
  • es diferente de (<>)
  • es mayor que (>)
  • es mayor o igual que (> =)
  • es menor que (<)
  • es menor o igual que (<=)

El «Valor si se cumple la condición» representa el valor devuelto por la fórmula si la condición emitida es verdadera en el caso de la celda seleccionada. Si la condición es falsa, aparecerá el «Valor si no se cumple la condición».

Diferentes funciones de Excel
Así es como se estructura la función SI.

Contrariamente a lo que uno podría pensar, la respuesta dada por la fórmula no está necesariamente en cifras. Si las respuestas proporcionan texto, entonces la fórmula también mostrará un texto. Las respuestas pueden ser números, texto, celdas:

  • =SI(A2>10, «Sí», «No»)
  • =SI(A2>10, A4, 0)

La comparación lógica se puede usar, por ejemplo, admitiendo un valor «a» en la primera celda (A1), una condición como «es más grande que “b”», la fórmula será entonces :

SI(A1>b; «Sí»; «No»)

El resultado será entonces «Sí» o «No» con cada celda.

La función SI también se puede anidar en el caso de que se deban indicar varias condiciones para encontrar el resultado. Para ello, hay que utilizar las funciones SI anidándolas entre sí.

En este caso, las respuestas deben ir entre paréntesis. La fórmula es así:

=SI(B3>90; « A »;SI(B3>80; « B »;SI(B3>70; « C »)))

Cada condición debe formar parte de una de las respuestas de la anterior, por lo que debe haber un sistema de niveles para que funcione esta fórmula.

Echa un ojo también a nuestro artículo sobre cómo hacer un gráfico en Excel.

La función SI utilizada con la función Y

La función Y de Excel en la celda de una tabla dinámica o una tabla simple te permite hacer más fácil la adición de la función SI. El uso de la función Y disminuye la longitud de la fórmula y la hace más clara y fácil de crear.

Como hemos dicho antes, si entran en juego varias condiciones, hay que anidarlas para obtener un resultado correcto. Así, es necesario verificar la primera antes de pasar a la siguiente y usar un sistema de niveles, por lo que la fórmula es interminable e induce a error.

Al utilizar la función Y, la fórmula se simplifica mucho, ya que la función reemplaza todas las condiciones añadidas. El principio de la función Y es que la fórmula verifica primero todas las condiciones indicadas por Y, luego usa la última función SI para indicar el resultado. Si una de las condiciones no se cumple en el conjunto de la función Y, entonces la respuesta será negativa.

Por lo tanto, es posible crear una fórmula como esta:

=SI(Y(A1=«verdadero»;A2=«verdadero»;A3= «verdadero»)=VERDADERO; «todo es verdadero»; «todo no es verdadero»)

El resultado negativo indica que todo no es positivo, pero no necesariamente que todo sea negativo.

Cómo utilizar las funciones de Excel
Es importante organizarse para crear una fórmula.

Descubre también los atajos más útiles en Excel.

La función SI en combinación con la función O

Para crear fórmulas en una hoja de cálculo de Excel, y para usar comparaciones lógicas, existe la función SI, Y, pero también la función O. Al igual que la función Y, la función O se usa con la función SI para simplificar y aclarar los cálculos. Son funciones avanzadas del software para automatizar cálculos.

El problema con la función Y es que todas las condiciones deben ser verdaderas para obtener una respuesta positiva a la fórmula total. Gracias a la función O, puedes hacer que solo una condición entre todas las condiciones establecidas no sea verdadera.

Aquí está el tipo de fórmula que puedes encontrar:

=SI(O(A1=«verdadero»;A2=«verdadero»;A3= «verdadero»)=VERDADERO; «al menos una condición es verdadera»; «nada es verdadero»)

La respuesta es positiva con solo una condición probada, y la respuesta es negativa si todas las condiciones son falsas.

Al igual que con la función Y, la función O te permite usar solo dos funciones en lugar de cinco o veinte.

Las funciones Y y O también pueden usarse simultáneamente dentro de una función SI para poder ampliar el número y tipo de fórmulas posibles. Por lo tanto, es posible combinar las ventajas de la función Y (todas las condiciones deben ser probadas) y las de la función O (al menos una condición debe ser probada).

Usar las tres funciones al mismo tiempo permite calcular con tres condiciones, por ejemplo. En el caso de que quieras probar una condición, y al menos una de las otras dos, primero será necesario usar la función Y, y luego la función O, anidándolas en la función SI.

Utilidades en la vida diaria de las funciones de Excel
Las funciones te ayudarán a calcular los números en tu día a día.

Encuentra un curso seguridad informatica en Superprof.

La función NO en Excel

La función NO permite considerar un resultado según una condición que no se cumple. La función SI se usa para introducir la idea de condición, pero la función NO invierte el papel del resultado. Esta función hace posible dar un resultado positivo si la condición no está probada.

En este sentido, es similar al operador lógico de la diferencia (<>).

Así, la fórmula = SI(A1<>«español»; «extranjero; «europeo») dará el mismo resultado que =SI(NO (A4 =«español»; «extranjero; «europeo»).

La función NO también se puede introducir en la función SI al mismo tiempo que la función O y la función Y. Todas estas funciones complican la fórmula, pero facilitan su escritura y hacen posible realizar cálculos de forma simple y rápida con el software Microsoft Office.

¡Abre una hoja de Excel y prueba todas estas nuevas características! Pero si necesitas empezar por algo más básico o todo lo anterior ya lo dominas, echa un vistazo a cursos excel.

La función BUSCAR en Excel

La función BUSCAR sirve, como su nombre indica, para buscar. ¿Pero cómo? Para buscar un elemento en una determinada fila o una determinada columna y encontrar un valor desde esa misma posición en una segunda fila o columna.

La fórmula de BUSCAR es: BUSCAR(valor_buscado; vector_de_comparación; [vector_resultado])

Siendo:

  • valor_buscado: lo que estamos buscando a modo de referencia (puede ser número, un extracto de texto, un nombre de referencia…).
  • vector de comparación: dónde tenemos que buscar (normalmente un intervalo de celdas).
  • [vector_resultado]: lo que buscamos en sí que no sabíamos exactamente dónde estaba en varias celdas paralelas pero sabíamos que se encontraba en varias filas o columnas.

Por ejemplo, si necesitamos buscar la palabra ingresos en las columnas A y B tendremos que poner =BUSCAR(ingresos;A2:A10;B2:B10) para encontrar el valor ingresos en las celdas comprendidas entre A1 y A10 y que muestra el resultado que aparezca en el intervalo B1 a B10.

Variantes de la función buscar: BUSCARV

La función anterior es útil para buscar en un determinado segmento, pero sí no tenemos muy claro en qué parte de la hoja de cálculo está lo que buscamos, lo mejor es buscar en toda la tabla. Para ello tenemos la función BUSCARV.

La expresión de BUSCARV es: =BUSCARV(Valor que buscamos; intervalo en el que se busca ese valor; número de columna del intervalo que contiene el valor devuelto; Coincidencia exacta o Coincidencia aproximada, indicado como FALSO o VERDADERO)

Variantes de la función buscar: BUSCARH

La H de esta función significa horizontal. Así la función BUSCARH se emplea para buscar un valor en la fila superior de una tabla o una matriz de valores. Con esta búsqueda se obtiene un valor en esa misma columna de una fila especificada en la tabla o matriz.

Por lo tanto, se recomienda utilizar esta función cuando los valores de comparación que queremos obtener se encuentran en una fila situada en la parte superior de una tabla de datos. Ten en cuenta que la información que quieres obtener debe estar dentro de un número determinado de filas. Si no tienes claro en que líneas específicamente se encuentra la información, mejor usa BUSCARV.

La fórmula de la función BUSCARH es =BUSCARH(valor_buscado, matriz_buscar_en, indicador_filas, [ordenado])

Siendo:

  • valor_buscado: elemento que estamos buscando a modo de referencia (una cifra, un número, un extracto de texto, un nombre de referencia…).
  • matriz_buscar_en: tabla de información en la que se buscan los datos.
  • indicador_filas: número de fila en matriz_tabla desde el cual se devolverá el valor que coincide.
  • ordenado: es opcional. Indica un valor lógico que especifica si la función debe localizar una coincidencia exacta o aproximada.
La funcion NO en Excel
Olvídate de hacer las cuentas a mano con Excel.
Los/las mejores profesores/as de Informática que están disponibles
José angel
4,9
4,9 (43 opiniones)
José angel
6€
/h
Gift icon
¡1a clase gratis!
Pedro
4,9
4,9 (10 opiniones)
Pedro
12€
/h
Gift icon
¡1a clase gratis!
Rony
5
5 (37 opiniones)
Rony
30€
/h
Gift icon
¡1a clase gratis!
Juan
4,9
4,9 (11 opiniones)
Juan
25€
/h
Gift icon
¡1a clase gratis!
Arber
4,9
4,9 (5 opiniones)
Arber
25€
/h
Gift icon
¡1a clase gratis!
Daniel
4,9
4,9 (12 opiniones)
Daniel
35€
/h
Gift icon
¡1a clase gratis!
Edgar
4,8
4,8 (11 opiniones)
Edgar
25€
/h
Gift icon
¡1a clase gratis!
Gloria
5
5 (12 opiniones)
Gloria
17€
/h
Gift icon
¡1a clase gratis!
José angel
4,9
4,9 (43 opiniones)
José angel
6€
/h
Gift icon
¡1a clase gratis!
Pedro
4,9
4,9 (10 opiniones)
Pedro
12€
/h
Gift icon
¡1a clase gratis!
Rony
5
5 (37 opiniones)
Rony
30€
/h
Gift icon
¡1a clase gratis!
Juan
4,9
4,9 (11 opiniones)
Juan
25€
/h
Gift icon
¡1a clase gratis!
Arber
4,9
4,9 (5 opiniones)
Arber
25€
/h
Gift icon
¡1a clase gratis!
Daniel
4,9
4,9 (12 opiniones)
Daniel
35€
/h
Gift icon
¡1a clase gratis!
Edgar
4,8
4,8 (11 opiniones)
Edgar
25€
/h
Gift icon
¡1a clase gratis!
Gloria
5
5 (12 opiniones)
Gloria
17€
/h
Gift icon
¡1a clase gratis!
Vamos

La función ENCONTRAR

Esta función sirve para encontrar una cadena de texto dentro de otra cadena de texto. Lo que obtenemos es la posición inicial de la primera cadena. Se utiliza principalmente para extraer una parte de algún concepto completo combinado.

La expresión de la función ENCONTRAR es =ENCONTRAR(texto_buscado; dentro_del_texto; [número_inicial])

Siendo:

  • texto buscado: expresión escrita que buscamos (hay que ponerla entre comillas).
  • dentro del texto: celda en la que se encuentra la expresión.
  • número inicial: es opcional. Podemos ponerlo para que la búsqueda empiece a partir de un carácter en concreto.

Variantes de la función ENCONTRAR: ENCONTRARB

La función ENCONTRAR está pensada para buscar elementos que estén escritos en idiomas que usan el conjunto de caracteres de un byte (SBCS), como es el español, el inglés o el portugués. Sin embargo, para aquellos idiomas que usan el conjunto de caracteres de doble byte (DBCS) se recomienda utilizar la función ENCONTRARB, como para el coreano, el japonés y el chino.

La fórmula de la función ENCONTRARB es =ENCONTRARB(texto_buscado; dentro_del_texto; [núm_inicial])

Siendo, igual que en el anterior caso:

  • texto buscado: expresión escrita que buscamos (hay que ponerla entre comillas).
  • dentro del texto: celda en la que se encuentra la expresión.
  • núm_inicial: no es obligatorio. Podemos ponerlo para que la búsqueda empiece a partir de un carácter en concreto.

La función COINCIDIR en las tablas de Excel

Con la función COINCIDIR podemos buscar valores iguales dentro de un rango concreto, es decir, buscamos un valor en un rango de celdas determinado y obtenemos la posición de ese valor en el rango que habíamos indicado.

La expresión de la función COINCIDIR es: =COINCIDIR(valor;A1:A10;0)

¿Qué significa ese 0 después del intervalo? Que el primer valor que aparece es exactamente igual al valor buscado. Podemos buscar coincidencias respondiendo a tres criterios, que va indicado con ese número final:

  • 0: se obtiene el primer valor exactamente igual que el valor buscado
  • 1: se obtiene el valor mayor que es menor o igual que el valor buscado
  • –1: se obtiene el valor menor que es mayor o igual que el valor buscado

La función ELEGIR en el programa Excel

Las funciones de excel más usadas
Al principio lleva tiempo utilizar Excel, pero luego te lo ahorrarás. Foto de Samuel Sianipar.

Esta función solo se puede utilizar en una lista que no supere los 254 elementos.

La fórmula de ELEGIR es: =ELEGIR(valor;A2;A3;A4;A5)

Al usar esta función estaremos eligiendo el valor que queremos dentro del rango de celdas que hemos indicado.

La función INDICE en Excel

Esta función nos permite obtener una referencia de una celda (o de una matriz de celdas) desde un rango o una tabla.

La fórmula de la función INDICE es =INDICE(matriz; núm_fila; [núm_columna])

Siendo:

  • matriz: intervalo entre dos celdas de una o varias columnas entre las que hay que buscar.
  • núm_fila: número de la fila en la que hay que buscar.
  • núm_columna: número de la columna a la que hay que devolver el valor. Esta valor es opcional, se recomienda utilizarlo cuando hay varias columnas en la matriz.

Veamos un ejemplo. Si utilizamos la expresión =INDICE(A2:B9;3;2) donde A2:B9 es la matriz que integra las columnas A y B desde las filas 2 a 9. El 3 se refiere a que queremos el valor de la tercera fila, y como en la matriz hay dos columnas, incluimos otro 2 para indicar que queremos el valor de la segunda columna. Puede ser un poco lioso pero una vez puesto en práctica queda más claro. ¡No dudes en probar en tu tabla de Excel!

La función FECHA en la tabla de Excel

Con los tres valores necesarios, día, fecha y hora, obtendremos una fecha. ¿Para qué sirve esto? Para obtener fechas de forma automática tras introducir valores en las columnas correspondientes a día, fecha y año.

La fórmula para obtener la fecha es =FECHA(C2,B2,A2), siendo C2 el año, B2 el mes y A2 el día.

Asegúrate del formato de fecha que deseas utilizar, ya que no es igual en todos los países. En España se utiliza el de día-mes-año (DD/MM/AAAA).

La función SUMA para sumar, restar, dividir y multiplicar

Como es la funcion 0 en excel
Como pongas algún elemento de la función mal... ¡error!

La función de SUMA es de las que primero se aprende al hacer un curso de Excel. Es sencilla de utilizar y muy práctica. Si tienes un trabajo con tareas administrativo-contables tienes que conocer esta función. También puede ser útil para llevar las cuentas de la economía doméstica o administrar tus facturas si eres autónomo.

La expresión de la función SUMA es: =SUMA(A1:A5)

Se suman las cifras que hay en el intervalo de las celdas entre A1 y A5, es decir, A1+A2+A3+A4+A5.

Si por cualquier motivo quieres sumarle a estas celdas una determinada cantidad, por ejemplo, 7, y obtener el resultado final, debes utilizar la siguiente función: =SUMA(7;A1:A5)

Señalar que aunque esta función se denomine «suma», también sirve para restar, multiplicar y dividir. Solo hay que cambiar el símbolo. Por lo tanto, tendríamos:

  • Para sumar: =SUMA(A1:A5)
  • Para restar: =SUMA(A1:A5)X
  • Para multiplicar: =SUMA(A1:A5)*X
  • Para dividir: =SUMA(A1:A5)/X

La función PROMEDIO en Excel

La función PROMEDIO se emplea para obtener la media aritmética de un conjunto de datos registrados en la tabla de Excel. Esto puede ser útil para multitud de tareas, como calcular la media de ingresos diarios, la media de productos vendidos a la semana, la media de edad de los usuarios de un servicio, etc.

La expresión para calcular el promedio de un conjunto de datos es =PROMEDIO(A1:A30), siendo A1 la primera cifra registrada (el primer día, la primera venta) y 30 la última.

También puede ocurrir que, por ejemplo, tenemos datos de los últimos tres meses, pero nosotros solo queremos saber el promedio de este último mes. Para ello debes poner en primer lugar el número de la celda del día a partir del cual quieres contar y después el número del último día a tener en cuenta para hacer la media.

La función SUMAPRODUCTO en una hoja de cálculo de Excel

Con la función SUMAPRODUCTO obtenemos la suma de los productos de los rangos o matrices seleccionados. Se puede utilizar para sumar, restar, multiplicar o dividir. Ten en cuenta que la función predeterminada de la función es la multiplicación.

La fórmula de la función SUMAPRODUCTO es =SUMAPRODUCTO(matriz1, [matriz2], [matriz3], ...)

Siendo:

  • matriz1: el primer argumento de matriz cuyos componentes deseamos multiplicar y después sumar.
  • matriz 2, matriz 3...: los componentes que deseamos multiplicar y sumar con los anteriores. Se puede seleccionar hasta un total de 255 matrices.

Para cambiar el tipo de operación, en la fórmula debes reemplazar las comas que separan los argumentos de matriz por los operadores aritméticos que quieras: (*) para multiplicar, (/) para dividir, (+) para sumar y (–) para restar.

La funcion FECHA y la funcion COINCIDIR en Excel
Saber usar Excel es un requisito para muchos empleos.

¿Controlas ya estas funciones? Descubre todas las utilidades de las hojas de cálculo con un profesor particular de Excel de Superprof.

>

La plataforma que conecta profes particulares y estudiantes

1ª clase gratis

¿Te gustó este artículo? ¡Puntúalo!

5,00 (4 nota(s))
Cargando...

Cristina

Redactora, traductora y revisora. Me encanta contar historias, escuchar a los demás y ver atardeceres. Me gusta bailar y perderme haciendo senderismo. Mi lugar preferido es el mar, que todo lo cura.